Elza a její požadavky

Autor: Kitty
S novou verzí označenou jako 2.1 (což je označení pro finální verzi Elzy (už žádná BETA) jsem se rozhodl sepsat její požadavky a potřeby. Neboli co všechno Elza baští, co nebaští a hlavně kde žije a co má ráda.Základní požadavky na běhání Elzy jsou dva. PHP 5.0 (a novější verze) a MySQL 5.0 (a novější verze). Oproti verzi  1.5 Elza přešla právě na stabilnější a efektivnější verzi MySQL. Starší verze si vystačila s databázovým strojem verze 4.0.
Další dobroty, které má Elza ráda jsou JavaScript a HTML 4.1. Všechny DataGridy (výstupy do tabulek) využívají moderní technologii AJAX. Díky tomu lze snadno vyhledávat, filtrovat a vůbec velice příjemě s Elzou pracovat. Nejen Datagrid využíví AJAXu. Většina prostředí byla vylepšena a spolu s novým vzhledem využívá právě AJAXových prvků, takže není nutné obnovit celou stránku jen kvůli přečtení vzkazů nebo jejich smazání.
Další novinkou v Elze je využití vynikajícího JavaScriptového Frameworku (něco jako polotovar při vaření) JQuery. Díky tomu je zajištěna kompatibilita s modernímy prohlížeči. Dokonce i prohlížeč na IPhonu nebo prohlížeč v systému Google Android si s Elzou poradí na jedničku!
V současnosti jsou podporovány tyto prohlížeče: InternetExplorer od verze 6 (doporučuji těm kdo chějí používat tuhle hrůzu verzi IE 8 a novější), Firefox je podporován od verze 1.5 (doufám že všichni mají verzi 3.5 a novější) a Google Chrome od verze 2.0 (kvůli kompletnímu JavaScriptu). Poslední jmenovaný mimochodem doporučuji. Má nejrychlejší zpracování JavaScriptu a tedy i nejlépe zvládá všechny novinky a vylepšení.

Počet přečtení: 2454
Kategorie:
Přihlášen: Problémy prosím hlaste na: grovik(kyselá čudla)grovik.net popřípadně kitty(kyselá čudla)grovik.net SZ na diskusích.
Elza už má 3075 záznamů.© Josef Němec - PHP, fotografieData jsou majetkem zadávajících. RSS